summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-07-12 23:53:14 -0700
committerAlan Coopersmith <alanc@alf.(none)>2006-07-12 23:53:14 -0700
commit9062a6da402d416f21d4365d3c3a29ceea707e77 (patch)
treedbda2b5d39faf05f6cf5c8a489b059b499b96632 /Makefile.am
parent9b5a14e6de65658fdb712e737b292568a69dc3ee (diff)
Replace static ChangeLog with dist-hook to generate from git-log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6008b3d..9c8bc12 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,7 +50,7 @@ CLEANFILES = $(libman_DATA) $(BUILT_SOURCES)
libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@) \
$(Xau_shadows:=.@LIB_MAN_SUFFIX@)
-EXTRA_DIST = xau.pc.in $(libman_PRE)
+EXTRA_DIST = xau.pc.in $(libman_PRE) ChangeLog
Xau_shadows = \
XauFileName \
@@ -75,3 +75,10 @@ XORGRELSTRING = @PACKAGE_STRING@
Xau.$(LIB_MAN_SUFFIX): $(srcdir)/Xau.man
sed 's/__xorgversion__/"$(XORGRELSTRING)" "$(XORGMANNAME)"/' \
< $(srcdir)/Xau.man > Xau.$(LIB_MAN_SUFFIX)
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ git-log > ChangeLog
+
+dist-hook: ChangeLog