summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 2 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index eca100e..017f704 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,30 +62,9 @@ dnl XXX incomplete, please fill this in
XAU_CFLAGS="$XAU_CFLAGS $XTHREAD_CFLAGS"
fi
-# Allow checking code with lint, sparse, etc.
-AC_ARG_WITH(lint, [AC_HELP_STRING([lint],
- [Use a lint-style source code checker (default: disabled)])])
-if test "x$with_lint" = "xyes" ; then
- LINT="lint"
-else
- LINT="$with_lint"
-fi
-if test "x$LINT_FLAGS" = "x" -a "x$LINT" != "xno" ; then
- case $LINT in
- lint|*/lint)
- case $host_os in
- solaris*)
- LINT_FLAGS="-u -b -h -erroff=E_INDISTING_FROM_TRUNC2"
- ;;
- esac
- ;;
- esac
-fi
-
+dnl Allow checking code with lint, sparse, etc.
+XORG_ENABLE_LINT
LINT_FLAGS="${LINT_FLAGS} ${XAU_CFLAGS}"
-AC_SUBST(LINT)
-AC_SUBST(LINT_FLAGS)
-AM_CONDITIONAL(LINT, [test x$LINT != xno])
if test "x$GCC" = "xyes"; then
GCC_WARNINGS="-Wall -Wpointer-arith -Wstrict-prototypes \