summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-08-30 08:50:40 -0400
committerGaetan Nadon <memsize@videotron.ca>2011-09-01 13:41:47 -0400
commit8b258c863c4f19c03378f33ca9bf37d31e402b21 (patch)
tree940f90b2f77ee1bdd658c1958759151fef75d91b /configure.ac
parent8907c4a3fe20158a42748258f3cce978acc8e272 (diff)
Rename XAW3D_CFLAGS to XAW3D_CPPFLAGS as it contains preprocessor options only
This will also prevent confusion as it is not obtained from PKG_CHECK_MODULES but follows its naming convention. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 28decd4..db38535 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,11 +33,11 @@ PKG_CHECK_MODULES(X11, [x11 xt xmu])
AC_CHECK_HEADERS([wctype.h wchar.h widec.h])
AC_CHECK_FUNCS([iswspace])
-XAW3D_CFLAGS=
+XAW3D_CPPFLAGS=
AC_ARG_ENABLE([internationalization],
[AS_HELP_STRING([--enable-internationalization], dnl
- [enable utf8 strings])], [XAW3D_CFLAGS="${XAW3D_CFLAGS} -DXAW_INTERNATIONALIZATION"])
+ [enable utf8 strings])], [XAW3D_CPPFLAGS="${XAW3D_CPPFLAGS} -DXAW_INTERNATIONALIZATION"])
AM_CONDITIONAL(XAW_INTERNATIONALIZATION,
[test x${enable_internationalization} = xyes])
@@ -45,18 +45,18 @@ AM_CONDITIONAL(XAW_INTERNATIONALIZATION,
AC_ARG_ENABLE([multiplane-bitmaps],
[AS_HELP_STRING([--enable-multiplane-bitmaps], dnl
[enable XPM support])],
- [XAW3D_CFLAGS="${XAW3D_CFLAGS} -DXAW_MULTIPLANE_PIXMAPS" dnl
+ [XAW3D_CPPFLAGS="${XAW3D_CPPFLAGS} -DXAW_MULTIPLANE_PIXMAPS" dnl
PKG_CHECK_MODULES(XPM, xpm)])
AC_ARG_ENABLE([gray-stipples],
[AS_HELP_STRING([--enable-gray-stipples], dnl
- [enable gray stipples])], [XAW3D_CFLAGS="${XAW3D_CFLAGS} -DXAW_GRAY_BLKWHT_STIPPLES"])
+ [enable gray stipples])], [XAW3D_CPPFLAGS="${XAW3D_CPPFLAGS} -DXAW_GRAY_BLKWHT_STIPPLES"])
AC_ARG_ENABLE([arrow-scrollbars],
[AS_HELP_STRING([--enable-arrow-scrollbars], dnl
- [enable arrow scrollbars])], [XAW3D_CFLAGS="${XAW3D_CFLAGS} -DXAW_ARROW_SCROLLBARS"])
+ [enable arrow scrollbars])], [XAW3D_CPPFLAGS="${XAW3D_CPPFLAGS} -DXAW_ARROW_SCROLLBARS"])
-AC_SUBST(XAW3D_CFLAGS)
+AC_SUBST(XAW3D_CPPFLAGS)
AC_CONFIG_FILES([Makefile
include/Makefile