summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2011-08-02 00:29:08 -0400
committerMatt Turner <mattst88@gmail.com>2011-08-02 00:29:08 -0400
commit017fcf81745d7a58a57a040fce86063719431f60 (patch)
tree8cc2080b35ca549c8303c21fd4229e8b78647aaf /configure.ac
parentd78a0a651839f94027f5d28b1cb8877034a92fd1 (diff)
configure.ac: Check for required dependencies.
Signed-off-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5a25149..50e38f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,7 +28,7 @@ AC_CONFIG_COMMANDS([libtool_hack], [
test -z "$SED" && SED=sed
$SED '1,/^soname_spec/{
/^soname_spec/i\
-# X.Org hack to match monolithic Xaw SONAME\
+# X.Org hack to match monolithic Xaw3d SONAME\
xorglibxawname="libXaw3d"
/^soname_spec/s/libname/xorglibxawname/
}' libtool_ > libtool
@@ -54,6 +54,7 @@ AM_CONDITIONAL(PLATFORM_WIN32, test "x$platform_win32" = "xyes")
AM_CONDITIONAL(PLATFORM_DARWIN, test "x$platform_darwin" = "xyes")
# Checks for header files.
+PKG_CHECK_MODULES(X11, [x11, xt, xmu])
AC_CHECK_HEADERS([wctype.h wchar.h widec.h])
AC_CONFIG_FILES([Makefile