summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRafał Mużyło <galtgendo@o2.pl>2011-08-03 17:05:14 +0200
committerMatt Turner <mattst88@gmail.com>2011-08-03 17:15:28 -0400
commitd5fc71efc7cb10728b1cfbadc16afef22b2ca12f (patch)
treec1527607fb653018de1554b92be88f26e81584cd /configure.ac
parentd651581036e9ee0048c6c25b37fb0f7b9e87789b (diff)
use four build time defines
Signed-off-by: Rafał Mużyło <galtgendo@o2.pl> Signed-off-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac67a22..3e1bead 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,31 @@ PKG_CHECK_MODULES(X11, [x11 xt xmu])
AC_CHECK_HEADERS([wctype.h wchar.h widec.h])
AC_CHECK_FUNCS([iswspace])
+XAW3D_CFLAGS=
+
+AC_ARG_ENABLE([internationalization],
+ [AS_HELP_STRING([--enable-internationalization], dnl
+ [enable utf8 strings])], [XAW3D_CFLAGS="${XAW3D_CFLAGS} -DXAW_INTERNATIONALIZATION"])
+
+AM_CONDITIONAL(XAW_INTERNATIONALIZATION,
+ [test x${enable_internationalization} = xyes])
+
+AC_ARG_ENABLE([multiplane-bitmaps],
+ [AS_HELP_STRING([--enable-multiplane-bitmaps], dnl
+ [enable XPM support])],
+ [XAW3D_CFLAGS="${XAW3D_CFLAGS} -DXAW_MULTIPLANE_PIXMAPS" dnl
+ PKG_CHECK_MODULES(XPM, xpm)])
+
+AC_ARG_ENABLE([gray-stipples],
+ [AS_HELP_STRING([--enable-gray-stipples], dnl
+ [enable gray stipples])], [XAW3D_CFLAGS="${XAW3D_CFLAGS} -DXAW_GRAY_BLKWHT_STIPPLES"])
+
+AC_ARG_ENABLE([arrow-scrollbars],
+ [AS_HELP_STRING([--enable-arrow-scrollbars], dnl
+ [enable arrow scrollbars])], [XAW3D_CFLAGS="${XAW3D_CFLAGS} -DXAW_ARROW_SCROLLBARS"])
+
+AC_SUBST(XAW3D_CFLAGS)
+
AC_CONFIG_FILES([Makefile
include/Makefile
src/Makefile])