summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 550f3fe..812d759 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,12 @@ AC_PROG_YACC
# Initialize libtool
AC_PROG_LIBTOOL
+# Require xorg-macros minimum of 1.8 for XORG_DEFAULT_OPTIONS with XORG_INSTALL
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
+
# Some compilers do not support per target -c and -o flags
AM_PROG_CC_C_O