summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-08-21 19:33:00 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-08-21 19:33:00 -0700
commita9ccf1bd91ad6e06f7b7116efe836c365b68645b (patch)
treedd3ba574f24c6afb94294c7c9ba7fc22056c2828 /configure.ac
parent110131bd40d0fc042f4a81922372307a1582b591 (diff)
Use cursorpath found by configure in man page
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6376ef5..18ca5db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,7 +51,10 @@ AC_ARG_WITH(icondir,
[ICONDIR=${datadir}/icons])
AC_SUBST([ICONDIR])
-DEF_CURSORPATH="~/.icons:${datadir}/icons:${datadir}/pixmaps:$ICONDIR"
+DEF_CURSORPATH="~/.icons:${datadir}/icons:${datadir}/pixmaps"
+if test "x${ICONDIR}" != "x${datadir}/icons"; then
+ DEF_CURSORPATH="${DEF_CURSORPATH}:${ICONDIR}"
+fi
AC_ARG_WITH(cursorpath,
AC_HELP_STRING([--with-cursorpath=<paths>],
[Set default search path for cursors]),
@@ -59,6 +62,10 @@ AC_ARG_WITH(cursorpath,
[XCURSORPATH=$DEF_CURSORPATH])
AC_SUBST([XCURSORPATH])
+# Reformat cursor path for man page
+XCURSORPATH_LIST=`echo $XCURSORPATH | sed 's/:/, /g'`
+AC_SUBST([XCURSORPATH_LIST])
+
# Check for X
PKG_CHECK_MODULES(XCURSOR, xrender >= 0.8.2 xfixes x11 fixesproto)
AC_DEFINE(HAVE_XFIXES, 1, [Define to 1 if you have Xfixes])