summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:28 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:28 -0500
commite211f3647823d89dd25a1cff8981c3154a6c429d (patch)
treec2a87dcef6124d81679ab14e3e5100909386e727 /Makefile.am
parentcad41f810023db454f33feea4f89d4d053737732 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ce5edbf..174b099 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,3 +29,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xfixes.pc
EXTRA_DIST = xfixes.pc.in autogen.sh
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog