summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-17 16:11:26 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-17 16:11:26 +0000
commit03d31637787906378bc2809758b6dbfe79ea55ad (patch)
tree24a87bfbb7d8a056fbdbc1cd6b88612d5bbbeb33 /configure.ac
parent7d85687a6d8319ac1a48e0294228632ffbefdc8a (diff)
Remove rest of half-removed if statement
remove irrelevant entries
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 3 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index 48f72c0..1195487 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,51 +45,16 @@ AC_PROG_CC
AC_PROG_LIBTOOL
# Check for X
-PKG_CHECK_MODULES(X, x11,
- [x_found_with_pkgconfig=yes],
- [x_found_with_pkgconfig=no])
+PKG_CHECK_MODULES(X, x11)
+
AC_SUBST(X_CFLAGS)
AC_SUBST(X_LIBS)
-if test "$x_found_with_pkgconfig" = "no"
-then
- AC_PATH_XTRA
- X_LIBS="$X_LIBS -lX11"
-
- if test "x$no_x" = "xyes"
- then
- AC_MSG_ERROR([X is required, but it was either disabled or not found.])
- fi
-
- save_LIBS="$LIBS"
- save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $X_CFLAGS"
- LIBS="$LIBS $X_LIBS"
-
- AC_MSG_CHECKING([for XTHREADS in Xlib])
- AC_RUN_IFELSE(
- [AC_LANG_PROGRAM([[#include <X11/Xlib.h>]],
- [[return XInitThreads() == 0 ? 0 : 1;]])],
- [xthreads=no],
- [xthreads=yes],
- [xthreads=yes])
-
- AC_MSG_RESULT($xthreads)
-
- LIBS="$save_LIBS"
- CFLAGS="$save_CFLAGS"
-
- if test "x$xthreads" = "xyes"
- then
- X_CFLAGS="$X_CFLAGS -DXTHREADS"
- fi
-fi
-
# Check fixesext configuration, strip extra digits from package version to
# find the required protocol version
FIXESEXT_VERSION=[`echo $VERSION | sed 's/^\([0-9][0-9]*\.[0-9][0-9]*\).*$/\1/'`]
-PKG_CHECK_MODULES(FIXESEXT, [fixesext >= $FIXESEXT_VERSION])
+PKG_CHECK_MODULES(FIXESEXT, [fixesproto >= $FIXESEXT_VERSION])
AC_SUBST(FIXESEXT_CFLAGS)
AC_SUBST(FIXESEXT_LIBS)