summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2013-04-13 10:20:59 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2013-05-03 23:53:29 -0700
commitb031e3b60fa1af9e49449f23d4a84395868be3ab (patch)
tree62d95f77e6d029fa06b9772d2d8d51421b5b5877 /configure.ac
parentf870dfb47da9d43d1750ea5e5fc9288c4158f7ad (diff)
Use _XEatDataWords to avoid overflow of _XEatData calculations
rep.length is a CARD32, so rep.length << 2 could overflow in 32-bit builds Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b942ffa..bb8e976 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,13 @@ AC_SUBST(FIXESEXT_VERSION)
# Obtain compiler/linker options for depedencies
PKG_CHECK_MODULES(FIXESEXT, xproto [fixesproto >= $FIXESEXT_VERSION] xextproto x11)
+# Check for _XEatDataWords function that may be patched into older Xlib releases
+SAVE_LIBS="$LIBS"
+LIBS="$FIXESEXT_LIBS"
+AC_CHECK_FUNCS([_XEatDataWords])
+LIBS="$SAVE_LIBS"
+
+
AC_CONFIG_FILES([Makefile
src/Makefile
man/Makefile