summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-08-25 17:51:04 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-08-25 17:51:04 -0700
commitcd09f4d54045b957d728d853398d62543d687d03 (patch)
tree9372673a6b7e3ab4d6d02fe3762289b51fdee5ed /Makefile.am
parent8d171fe61e564d8ed8f75034d4191062cecf190b (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fbe5345..544f0db 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,4 +45,12 @@ libXfontinclude_HEADERS = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xfont.pc
-EXTRA_DIST = xfont.pc.in autogen.sh include/X11/fonts/fontconf.h.in
+EXTRA_DIST = xfont.pc.in autogen.sh include/X11/fonts/fontconf.h.in ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ GIT_DIR=${srcdir}/.git git-log > ChangeLog
+
+dist-hook: ChangeLog
+