summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2013-05-01 23:58:39 -0700
committerPeter Hutterer <peter.hutterer@who-t.net>2013-05-24 11:46:37 +1000
commit4579fadd11883c62db486ecc64c40342c2ab5506 (patch)
treeb9d9885fd0b8c53dad6265109e304a71b7d07126 /configure.ac
parent768c64aaf9d89b1b94f873c68b6b5b38a3af79fa (diff)
Use _XEatDataWords to avoid overflow of rep.length bit shifting
rep.length is a CARD32, so rep.length << 2 could overflow in 32-bit builds Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net> (cherry picked from commit 59b8e1388a687f871831ac5a9e0ac11de75e2516)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31f0931..7441769 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,12 @@ XORG_CHECK_MALLOC_ZERO
# Obtain compiler/linker options for dependencies
PKG_CHECK_MODULES(XI, [xproto >= 7.0.13] [x11 >= 1.4.99.1] [xextproto >= 7.0.3] [xext >= 1.0.99.1] [inputproto >= 2.1.99.6])
+# Check for _XEatDataWords function that may be patched into older Xlib releases
+SAVE_LIBS="$LIBS"
+LIBS="$XI_LIBS"
+AC_CHECK_FUNCS([_XEatDataWords])
+LIBS="$SAVE_LIBS"
+
# Check for xmlto and asciidoc for man page conversion
# (only needed by people building tarballs)
if test "$have_xmlto" = yes && test "$have_asciidoc" = yes; then