summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2013-03-26 14:46:06 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2013-04-05 09:24:17 +1000
commit0358bb20384b759d6d41dc44f3aed30583689d53 (patch)
tree8a753b7060d73b28a9c624d22f7666c0cc24e32f /configure.ac
parent081e06492c0ffd003d4a0c34418c882332e58ac3 (diff)
Require XFixes for PointerBarrier, remove duplicate typedef
The PointerBarrier typedef is duplicate if a client includes both Xfixes.h and XInput2.h. gcc 4.6 won't complain about that, but earlier versions do: http://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=ce3765bf44e49ef0568a1ad4a0b7f807591d6412 gcc 4.6 with -pedantic-errors shows: /opt/xorg/include/X11/extensions/XInput2.h:172:13: error: redefinition of typedef ‘PointerBarrier’ [-pedantic] In file included from test.c:1:0: /opt/xorg/include/X11/extensions/Xfixes.h:255:13: note: previous declaration of ‘PointerBarrier’ was here Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Julien Cristau <jcristau@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ab8a63c..c2897d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,8 @@ XORG_CHECK_MALLOC_ZERO
# Obtain compiler/linker options for dependencies
PKG_CHECK_MODULES(XI, [xproto >= 7.0.13] [x11 >= 1.4.99.1] [xextproto >= 7.0.3] [xext >= 1.0.99.1] [inputproto >= 2.2.99.1])
+# CFLAGS only for PointerBarrier typedef
+PKG_CHECK_MODULES(XFIXES, [xfixes >= 5])
# Check for xmlto and asciidoc for man page conversion
# (only needed by people building tarballs)