summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-01-23 10:04:38 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-01-24 07:32:41 -0500
commitc183e15263787af913bf8eb7be707e0f2e974824 (patch)
treec71413c1a220cd6573d66c6bf2c49d5799b1137a /configure.ac
parentc94494c144c634b7fa3187c55458cafa0e06a69c (diff)
man: allow installing prebuilt man pages from tarball
The man pages source may be supplied in the tarball or built from git. The makefile needs to take that into consideration and adjust the targets accordingly. Reviewed-by: Dan Nicholson <dbn.lists@gmail.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 347dcef..68983c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,11 @@ XI_CFLAGS="$CWARNFLAGS $XI_CFLAGS"
AC_SUBST(XI_CFLAGS)
AC_SUBST(XI_LIBS)
+# Determine if the source for man pages is available
+# It may already be present (tarball) or can be generated using xmlto
+AM_CONDITIONAL([INSTALL_MANPAGES],
+ [test -f "$srcdir/man/XAllowDeviceEvents.man" || test "x$have_xmlto" = xyes])
+
# Check for xmlto and asciidoc for man page conversion
# (only needed by people building tarballs)
AM_CONDITIONAL([HAVE_DOCTOOLS], [test "x$XMLTO" != "x" && test "x$ASCIIDOC" != "x"])