summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter@cs.unisa.edu.au>2008-04-30 10:35:12 +0930
committerPeter Hutterer <peter@cs.unisa.edu.au>2008-04-30 10:35:12 +0930
commit26dde5aaf4bbc89140cc4e3d13fe18036041022d (patch)
tree6ab61c4d32ce9539272f1f3935fc06881ac224de /src/Makefile.am
parentd68d321c0692848dd5eb67a3713676498c1c646b (diff)
Fix up AM_CFLAGS, pulled in the system-includes before the local ones.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 15ed76b..b81546f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -58,9 +58,12 @@ libXi_la_SOURCES = \
libXi_la_LIBADD = $(XI_LIBS)
-AM_CFLAGS = $(XI_CFLAGS) $(MALLOC_ZERO_CFLAGS)
+AM_CFLAGS = -I$(top_srcdir)/include \
+ -I$(top_srcdir)/include/X11 \
+ -I$(top_srcdir)/include/X11/extensions \
+ $(XI_CFLAGS) \
+ $(MALLOC_ZERO_CFLAGS)
-INCLUDES = -I$(top_srcdir)/include/X11/extensions
libXi_la_LDFLAGS = -version-number 6:0:0 -no-undefined