summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Byer <bbyer@bbyer.(none)>2007-02-20 01:05:27 -0800
committerBen Byer <bbyer@bbyer.(none)>2007-02-20 01:05:27 -0800
commit4e7031510d05471e77ff48355b23fc8e4302648c (patch)
tree4beb3b27fe648ff7f8be62d5c412684f29c58238 /configure.ac
parent92452ca7a51fa77ea60eacd320dbd970e32653c9 (diff)
added -flat_namespace to CFLAGS for Darwin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b5bcf13..407112a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,6 +95,17 @@ case $host_os in
esac
AC_SUBST(STRINGSABIOPTIONS)
+case $host_os in
+ darwin*)
+ OS_CFLAGS="-Wl,-flat_namespace"
+ ;;
+ *)
+ OS_CFLAGS=
+ ;;
+esac
+
+CFLAGS="$CFLAGS $OS_CFLAGS"
+
# Man page processing requirements
XORG_PROG_RAWCPP
XORG_MANPAGE_SECTIONS