summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2015-01-18 11:21:45 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2015-01-25 19:51:44 -0800
commitca04f74887d53c75e794f643f7e860ba588c3a57 (patch)
treeb43c370c08e83ed32b0199c35a111fe3ae4ba175 /configure.ac
parentfba83e45a8d5dc2ca920ec6c49446d2b54c2db5c (diff)
makestrs: Use asprintf() if available
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 34e6aab..3633ec6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,10 @@ if test x"$CC_FOR_BUILD" = x; then
fi
fi
AC_SUBST([CC_FOR_BUILD])
-CPPFLAGS_FOR_BUILD=${CPPFLAGS_FOR_BUILD-${CPPFLAGS}}
+DEFAULT_CPPFLAGS_FOR_BUILD="${CPPFLAGS}"
+AC_CHECK_FUNC(asprintf,
+ [DEFAULT_CPPFLAGS_FOR_BUILD="${DEFAULT_CPPFLAGS_FOR_BUILD} -DHAVE_ASPRINTF"])
+CPPFLAGS_FOR_BUILD=${CPPFLAGS_FOR_BUILD-${DEFAULT_CPPFLAGS_FOR_BUILD}}
AC_SUBST(CPPFLAGS_FOR_BUILD)
DEFAULT_CFLAGS_FOR_BUILD="${CFLAGS} ${CWARNFLAGS}"
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${DEFAULT_CFLAGS_FOR_BUILD}}