summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-09-18 16:14:11 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-09-18 16:14:11 -0700
commit8681d431516979dcffd1ca7a65d47026d8ad0336 (patch)
tree06430197d756c4df3cd5d3209f092a70709939a7 /Makefile.am
parentd19e0d1fe15de6b9a2bfffe30bd041497c021eaf (diff)
Add hooks for running code checkers like sparse & lint over the source
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6aacfa8..273cbed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,3 +32,8 @@ ChangeLog:
git-log > ChangeLog
dist-hook: ChangeLog
+
+if LINT
+lint:
+ (cd src && $(MAKE) $(MFLAGS) lint)
+endif LINT