summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2010-07-08 15:21:36 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2010-07-08 15:22:55 -0700
commit14cf5e3d19488f9a36824a01d4aba4a7f5ebc1cd (patch)
tree9a4e9ebdb1cc072e30275d92070a254e457333cf /man/Makefile.am
parente106f955dfc23798975ef14b3d3400aff39eced9 (diff)
config: upgrade to util-macros 1.8 for additional man page support
Use MAN_SUBST now supplied in XORG_MANPAGE_SECTIONS The value of MAN_SUBST is the same for all X.Org packages. Use AC_PROG_SED now supplied by XORG_DEFAULT_OPTIONS Enables use of platform appropriate version of sed. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am17
1 files changed, 5 insertions, 12 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 8b7d8e6..9d8a9ac 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -59,18 +59,11 @@ EXTRA_DIST = $(libman_PRE) xv-library-v2.2.txt
CLEANFILES = $(libman_DATA)
-SED = sed
-
-# Strings to replace in man pages
-XORGRELSTRING = @PACKAGE_STRING@
- XORGMANNAME = X Version 11
-
-MAN_SUBSTS = \
- -e 's/__vendorversion__/"$(XORGRELSTRING)" "$(XORGMANNAME)"/' \
- -e 's/__libmandirsuffix__/$(LIB_MAN_DIR_SUFFIX)/g' \
- -e 's/__libmansuffix__/$(LIB_MAN_SUFFIX)/g'
-
SUFFIXES = .$(LIB_MAN_SUFFIX) .man
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+ADDITIONAL_MAN_SUBSTS = \
+ -e 's|__libmandirsuffix__|$(LIB_MAN_DIR_SUFFIX)|g'
+
.man.$(LIB_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) $(ADDITIONAL_MAN_SUBSTS) < $< > $@