summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2022-03-25 14:55:36 -0700
committerMatt Turner <mattst88@gmail.com>2022-03-26 17:40:06 +0000
commitcdf1532b13efe667f40dd472f41b4e12a0282dea (patch)
treeb7b0faa61d543f9947c31755733378ec167582c0 /Makefile.am
parent324ecde7352e7a129f30b795a1c2d9142600aeea (diff)
meson: Add a meson build system
This does everything the autotools based system does, including building both a static and shared version by default, though this can be controlled with meson's builtin `default_library` option.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b07aa31..4e885eb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,4 +43,7 @@ lint:
(cd src && $(MAKE) $(MFLAGS) lint)
endif LINT
-EXTRA_DIST = README.md
+EXTRA_DIST = \
+ meson.build \
+ README.md
+