summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Joost <mehl@michael-joost.de>2013-11-18 16:11:26 +0100
committerAlan Coopersmith <alan.coopersmith@oracle.com>2013-11-22 23:18:57 -0800
commit62bc54e6995618b7134f5cbe3a4290e41a4cb44a (patch)
treee93be5ff6c914c09300e0f0795fa332ed0bf14b1 /configure.ac
parent9a39e26871e1f8ddb7086a53aba0b66a6fa6c7a9 (diff)
Remove fallback for _XEatDataWords, require libX11 1.6 for it
_XEatDataWords was orignally introduced with the May 2013 security patches, and in order to ease the process of delivering those, fallback versions of _XEatDataWords were included in the X extension library patches so they could be applied to older versions that didn't have libX11 1.6 yet. Now that we're past that hurdle, we can drop the fallbacks and just require libX11 1.6 for building new versions of the extension libraries. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 7c2a7e0..ea2de2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,13 +40,7 @@ XORG_DEFAULT_OPTIONS
XORG_CHECK_MALLOC_ZERO
# Obtain compiler/linker options for depedencies
-PKG_CHECK_MODULES(XVMC, x11 xext xv xextproto videoproto)
-
-# Check for _XEatDataWords function that may be patched into older Xlib release
-SAVE_LIBS="$LIBS"
-LIBS="$XVMC_LIBS"
-AC_CHECK_FUNCS([_XEatDataWords])
-LIBS="$SAVE_LIBS"
+PKG_CHECK_MODULES(XVMC, [x11 >= 1.6] xext xv xextproto videoproto)
# Checks for library functions.
AC_CHECK_FUNCS([shmat])