summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:43 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:43 -0500
commit7acb8e34e19ca4ac3347cd42c31adf877397f23b (patch)
treeeee9ab06a450c704c376c5d4e9d221f462c705b1 /Makefile.am
parent5968e0f1e992db63b003f2389657cd527a806efd (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 836c78e..047d332 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,3 +4,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xxf86dga.pc
EXTRA_DIST = xxf86dga.pc.in autogen.sh
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog