summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-08-17 19:53:37 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-08-17 19:53:37 -0400
commitb6d645596f284550350d8c690cfcce89d019ab60 (patch)
treed81a62911e5c364ea8d312ea29997a6b74c6c100 /man/Makefile.am
parent01df17daf923b7eeeb3476149d189c5dc8da3bf8 (diff)
man: store shadow man pages in git rather than generating them
Simplify the build process and the makefile. Local fix in CVS for bug 5628 is not required as the problem has been fixed in util-macros d9062e4077ebfd0985baf8418f3d0f111b9ddbba Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am62
1 files changed, 27 insertions, 35 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 0fc1db8..417dd03 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -23,18 +23,37 @@
libmandir = $(LIB_MAN_DIR)
-LIB_MAN_DIR_SUFFIX = $(LIB_MAN_DIR:@mandir@/man%=%)
+libman_PRE = \
+ XF86VM.man \
+ $(XF86VM_shadows:=.man)
-libman_PRE = XF86VM.man
-
-BUILT_SOURCES = $(XF86VM_shadowmen)
+XF86VM_shadows = \
+ XF86VidModeQueryExtension \
+ XF86VidModeQueryVersion \
+ XF86VidModeGetModeLine \
+ XF86VidModeGetAllModeLines \
+ XF86VidModeDeleteModeLine \
+ XF86VidModeModModeLine \
+ XF86VidModeSwitchMode \
+ XF86VidModeSwitchToMode \
+ XF86VidModeLockModeSwitch \
+ XF86VidModeGetMonitor \
+ XF86VidModeGetViewPort \
+ XF86VidModeSetViewPort \
+ XF86VidModeValidateModeLine \
+ XF86VidModeSetClientVersion \
+ XF86VidModeGetDotClocks \
+ XF86VidModeGetGamma \
+ XF86VidModeSetGamma \
+ XF86VidModeSetGammaRamp \
+ XF86VidModeGetGammaRamp \
+ XF86VidModeGetGammaRampSize \
+ XF86VidModeGetPermissions
EXTRA_DIST = $(libman_PRE)
+CLEANFILES = $(libman_DATA)
-CLEANFILES = $(libman_DATA) $(BUILT_SOURCES)
-
-libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@) \
- $(XF86VM_shadowmen)
+libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@)
# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
SUFFIXES = .$(LIB_MAN_SUFFIX) .man
@@ -42,31 +61,4 @@ SUFFIXES = .$(LIB_MAN_SUFFIX) .man
.man.$(LIB_MAN_SUFFIX):
$(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
-# Generate man page shadow files (Replaces InstallManPageAliases from Imake)
-
-XF86VM_shadows = \
- XF86VidModeQueryExtension \
- XF86VidModeQueryVersion \
- XF86VidModeGetModeLine \
- XF86VidModeGetAllModeLines \
- XF86VidModeDeleteModeLine \
- XF86VidModeModModeLine \
- XF86VidModeSwitchMode \
- XF86VidModeSwitchToMode \
- XF86VidModeLockModeSwitch \
- XF86VidModeGetMonitor \
- XF86VidModeGetViewPort \
- XF86VidModeSetViewPort \
- XF86VidModeValidateModeLine \
- XF86VidModeSetClientVersion \
- XF86VidModeGetDotClocks \
- XF86VidModeGetGamma \
- XF86VidModeSetGamma \
- XF86VidModeSetGammaRamp \
- XF86VidModeGetGammaRamp \
- XF86VidModeGetGammaRampSize \
- XF86VidModeGetPermissions
-XF86VM_shadowmen = $(XF86VM_shadows:=.@LIB_MAN_SUFFIX@)
-$(XF86VM_shadowmen):
- $(AM_V_GEN)echo ".so man$(LIB_MAN_DIR_SUFFIX)/XF86VM.$(LIB_MAN_SUFFIX)" > $@