summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-02-16 10:37:21 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-02-16 12:23:43 -0500
commita8b1449bca44bfddd2e7228bb7d514512e4ef30c (patch)
treea310958c5c581705e201fbb65bfe1461ff8fcff0 /src/Makefile.am
parent442b50b94eaae9202e76c170738fcc049dcc453d (diff)
config: move CWARNFLAGS from configure.ac to Makefile.am
Compiler warning flags should be explicitly set in the makefile rather than being merged with other packages compiler flags. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 434c56f..95f7908 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,7 +11,8 @@ AM_CFLAGS = -I$(top_srcdir)/include \
-I$(top_srcdir)/include/X11 \
-I$(top_srcdir)/include/X11/extensions \
$(DMX_CFLAGS) \
- $(MALLOC_ZERO_CFLAGS)
+ $(MALLOC_ZERO_CFLAGS) \
+ $(CWARNFLAGS)
libdmxincludedir = $(includedir)/X11/extensions
libdmxinclude_HEADERS = $(top_srcdir)/include/X11/extensions/dmxext.h