summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2022-05-08 11:14:11 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2022-05-08 11:15:19 -0700
commit3ff95c472abe8eb8fe1ccda5cd40d99407f1f9a4 (patch)
treed0de103c0810bc6a3b457f0491cc0cb5b3354740 /src/Makefile.am
parenta6a3bd1365798783f3fa5552d4ab061d5636d15a (diff)
Import reallocarray() from libX11 (originally from OpenBSD)
Wrapper for realloc() that checks for overflow when multiplying arguments together, so we don't have to add overflow checks to every single call. For documentation on usage, see: http://www.openbsd.org/cgi-bin/man.cgi/OpenBSD-current/man3/calloc.3 Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e37043b..b2df9a6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,7 +3,8 @@ lib_LTLIBRARIES = libfontenc.la
libfontenc_la_SOURCES = \
encparse.c \
fontenc.c \
- fontencI.h
+ fontencI.h \
+ reallocarray.h
AM_CFLAGS = \
$(FONTENC_CFLAGS) \
@@ -15,7 +16,7 @@ FONTENCDEFS = -DFONT_ENCODINGS_DIRECTORY=\"$(FONTENCDIR)/encodings.dir\"
AM_CPPFLAGS = -I$(top_srcdir)/include $(FONTENCDEFS)
-libfontenc_la_LIBADD = @FONTENC_LIBS@
+libfontenc_la_LIBADD = $(LTLIBOBJS) @FONTENC_LIBS@
libfontenc_la_LDFLAGS = -version-number 1:0:0 -no-undefined