summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-27 16:09:14 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-27 16:09:14 +0000
commitbcdcaebcd2127f4e7e1c368f341a781b4cf8af6b (patch)
tree256f1eb281aee121eecadf24cab1af4fdc5960c9 /src/Makefile.am
parente80fd1617092d128d54a9400a4974ffafbb3083e (diff)
- Remove fontenc from Xfont
- Add a dependency from Xfont on libfontenc - Add build system for lib/fontenc - xc/lib/font: Change #include "fontenc.h" to #include <X11/fonts/fontenc.h> in some places. - Remove dpsinfo and dpsexec from the app section of symlink.sh - Fix xp.pc.in to add XPRINT_LIBS/CFLAGS instead of X_LIBS/CFLAGS
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..343b7cd
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,21 @@
+lib_LTLIBRARIES = libfontenc.la
+
+libfontenc_la_SOURCES = \
+ encparse.c \
+ fontenc.c
+
+FONTDIR=${libdir}/X11/fonts
+FONTENCDEFS = -DFONT_ENCODINGS_DIRECTORY=\"$(FONTDIR)/encodings/encodings.dir\"
+
+INCLUDES = -I$(top_srcdir)/include/X11/fonts -DFONTENC_NO_LIBFONT $(FONTENCDEFS)
+
+
+libfontenc_la_LIBADD = @DEP_LIBS@
+
+libfontenc_la_LDFLAGS = -version-info 7:0:0 -no-undefined
+
+
+libfontencincludedir = $(includedir)/X11/fonts
+libfontencinclude_HEADERS = \
+ $(top_srcdir)/include/X11/fonts/fontenc.h
+