summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <idr@us.ibm.com>2006-04-12 22:56:50 +0000
committerIan Romanick <idr@us.ibm.com>2006-04-12 22:56:50 +0000
commit64af050c3803ed61837d9e9109c7a4e239a5c0b8 (patch)
tree9495dd82a3ba61665077646f4309c2046555c15a /src/Makefile.am
parent5b4db5c392c123f71a7933bd94c789b5e23dd69a (diff)
Bump to version 0.4.0.
Add multiple-inclusion protection. Add new function to write masked bits to PCI config space. This mirrors functionality currently available in X.org that is slated to be removed. Gut old regex based search mechanism with a new mechanism that is modeled after the Linux kernel. In addition to searching for devices by device / vendor ID, it is possible to search for devices by their domain / bus / slot / function. Fix serious bus in the reading of ROMs and in the unmapping of regions. The main point is that the map routine depens on the pci_mem_region::memory pointer being non-NULL only when the region is mapped. Therefore, the unmap routine should set it to NULL after unmapping. Update to use new search API.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f815ee5..d8d5472 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -34,7 +34,7 @@ INCLUDES = -I$(top_srcdir)/include
libpciaccess_la_LIBADD = @PCIACCESS_LIBS@
-libpciaccess_la_LDFLAGS = -version-number 0:3:0 -no-undefined
+libpciaccess_la_LDFLAGS = -version-number 0:4:0 -no-undefined
libpciaccessincludedir = $(includedir)
libpciaccessinclude_HEADERS = \