summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2014-03-26 15:40:56 -0400
committerUli Schlachter <psychon@znc.in>2014-08-06 13:29:16 +0200
commit529e3bfc2088dcd35e68a0a8394d0e9bff7c978b (patch)
tree94aea17c8fc45acb28a43ba7ab7197853ca89e88 /Makefile.am
parent74f552c1b39eb6a1ab64451477a492a2b22d9d7a (diff)
Add ChangeLog and INSTALL using xorg macros
Same as all other X modules. The one in libxcb git is removed. Those files are created during 'make dist' Reviewed-by: Josh Triplett <josh@joshtriplett.org> Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Uli Schlachter <psychon@znc.in>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e912489..2475b6e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,3 +97,15 @@ tools/api_conv.pl \
tools/constants \
autogen.sh \
$(TESTS)
+
+MAINTAINERCLEANFILES = ChangeLog INSTALL
+
+.PHONY: ChangeLog INSTALL
+
+INSTALL:
+ $(INSTALL_CMD)
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog INSTALL