summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2006-11-22 22:47:15 -0800
committerJosh Triplett <josh@freedesktop.org>2006-11-22 22:47:15 -0800
commit608058ec80edb041ca012d530b42d97474f80320 (patch)
tree877f61844c208038d974efea68d55d5eaf64c6dd /configure.ac
parent1aade6a15f767c49db5c1b69b97a5b1bf8cdce57 (diff)
Remove --with-opt and --with-debug options from configure.ac; use CFLAGS instead
configure supports using custom CFLAGS, so remove the --with-opt and --with-debug options from configure.ac, and the corresponding usage of COPTFLAGS and CDEBUGFLAGS in src/Makefile.am.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 0 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac
index c9fc555..0dd396d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,50 +61,6 @@ AC_SEARCH_LIBS(connect, socket)
xcbincludedir='${includedir}/xcb'
AC_SUBST(xcbincludedir)
-AC_ARG_WITH(opt,
-AC_HELP_STRING([--with-opt], [compile with reasonable optimizations])
-AC_HELP_STRING([--with-opt=FLAGS], [compile with specified FLAGS])
-AC_HELP_STRING([--with-opt=small], [compile for smallest code])
-AC_HELP_STRING([--without-opt], [compile without optimization (default)]),
-[
- case "$withval" in
- yes)
- COPTFLAGS="-O3"
- ;;
- small)
- COPTFLAGS="-Os -fomit-frame-pointer -DNDEBUG"
- ;;
- no)
- COPTFLAGS=""
- ;;
- *)
- COPTFLAGS="$withval"
- ;;
- esac
-])
-AC_CACHE_CHECK([what compiler optimizations to apply], [COPTFLAGS], [COPTFLAGS=""])
-AC_SUBST(COPTFLAGS)
-
-AC_ARG_WITH(debug,
-AC_HELP_STRING([--with-debug], [compile with debugging (default)])
-AC_HELP_STRING([--with-debug=FLAGS], [compile with specified debugging FLAGS])
-AC_HELP_STRING([--without-debug], [compile without debugging]),
-[
- case "$withval" in
- yes)
- CDEBUGFLAGS="-g"
- ;;
- no)
- CDEBUGFLAGS=""
- ;;
- *)
- CDEBUGFLAGS="$withval"
- ;;
- esac
-])
-AC_CACHE_CHECK([what debugging options to apply], [CDEBUGFLAGS], [CDEBUGFLAGS="-g"])
-AC_SUBST(CDEBUGFLAGS)
-
if test "x$GCC" = xyes ; then
CWARNFLAGS="-Wall -pedantic -Wpointer-arith \
-Wstrict-prototypes -Wmissing-declarations -Wnested-externs"