summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJamey Sharp <jamey@minilop.net>2006-02-23 22:41:59 -0800
committerJamey Sharp <jamey@minilop.net>2006-02-23 22:41:59 -0800
commit7f0bc778c88ab2f565cc05d5d3d5ee4c8d1388a1 (patch)
tree2c3a43f6dfa41d0bedde3fb0511e9a2455858d50 /configure.ac
parent6e29e5f2ee2e6158f1a9480a83e4f906ab9c04d1 (diff)
Factor padding out of _xcb_out_write_block and into its callers, XCBSendRequest and write_setup.
This requires dynamically allocating memory in XCBSendRequest, but this malloc/free pair turns out to cause a 30% speed hit for the 'x11perf -noop' test -- so for the moment I use alloca where available and fall back to malloc on other platforms. Later I think I'll change the contract of XCBSendRequest so the caller is responsible for memory allocation, because the caller ought to always be able to stack-allocate here.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5e4405c..a07a89e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,7 @@ AC_MSG_RESULT($XCBPROTO_XCBINCLUDEDIR)
AC_SUBST(XCBPROTO_XCBINCLUDEDIR)
AC_HEADER_STDC
+AC_FUNC_ALLOCA
AC_SEARCH_LIBS(gethostbyname, nsl)
AC_SEARCH_LIBS(connect, socket)