summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Linhart <chris@demorecorder.com>2017-01-20 20:14:57 +0100
committerChristian Linhart <chris@demorecorder.com>2017-03-11 10:51:33 +0100
commit0c2c5d50f8670da3e7601feb6a29b53509513da5 (patch)
tree357b6f56f930a069dcaf4729291977920c09a634 /configure.ac
parent9bce1f72e329cb407b7a95589b9675a08129b65d (diff)
optionally build the GE extension
xcb contains an xml-definition for the GenericEvent extension but this extension was neither generated nor built. This patch enables optional building of the GenericEvent extension with configure option --enable-ge By default, the GenericEvent extension is not built. Normally this is not needed by application programs because there is implicit support for the GE-extension for the specific events built with this extension. But it may be useful for X-protocol analyzers and stuff like that. Signed-off-by: Christian Linhart <chris@demorecorder.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ec31542..d3165c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,6 +220,7 @@ XCB_EXTENSION(Damage, yes)
XCB_EXTENSION(DPMS, yes)
XCB_EXTENSION(DRI2, yes)
XCB_EXTENSION(DRI3, $have_sendmsg)
+XCB_EXTENSION(GE, no)
XCB_EXTENSION(GLX, yes)
XCB_EXTENSION(Present, yes)
XCB_EXTENSION(RandR, yes)
@@ -271,6 +272,7 @@ xcb-damage.pc
xcb-dpms.pc
xcb-dri2.pc
xcb-dri3.pc
+xcb-ge.pc
xcb-glx.pc
xcb-present.pc
xcb-randr.pc
@@ -318,6 +320,7 @@ echo " Damage..............: ${BUILD_DAMAGE}"
echo " Dpms................: ${BUILD_DPMS}"
echo " Dri2................: ${BUILD_DRI2}"
echo " Dri3................: ${BUILD_DRI3}"
+echo " GenericEvent........: ${BUILD_GE}"
echo " Glx.................: ${BUILD_GLX}"
echo " Randr...............: ${BUILD_RANDR}"
echo " Record..............: ${BUILD_RECORD}"