summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Linhart <chris@demorecorder.com>2015-06-11 18:58:38 +0200
committerChristian Linhart <chris@demorecorder.com>2015-07-04 16:25:23 +0200
commitb15c96f9507119e5d38a61d92b4dbcd479ea2099 (patch)
treedabb250207f014311496ab9251b7090aadbbf021 /configure.ac
parentc5d923d8ff4a9b9fc1aef1c6c6918bab15098d34 (diff)
make support for server side stuff optional
and make it disabled by default with an EXPERIMENTAL warning reason: this feature is unfinished and we want to have flexibility for ABI/API changes, while still being able to make a release soon Signed-off-by: Christian Linhart <chris@demorecorder.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cce0ddb..f3120eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -252,6 +252,10 @@ if test "x$LAUNCHD" = xyes ; then
AC_DEFINE(HAVE_LAUNCHD, 1, [launchd support available])
fi
+AC_ARG_WITH(serverside-support, AS_HELP_STRING([--with-serverside-support], [Build with support for server-side usage of xcb. This is still EXPERIMENTAL! ABI/API may change! (default: no)]), [XCB_SERVERSIDE_SUPPORT=$withval], [XCB_SERVERSIDE_SUPPORT=no])
+
+AM_CONDITIONAL(XCB_SERVERSIDE_SUPPORT, test "x$XCB_SERVERSIDE_SUPPORT" = "xyes")
+
AC_CONFIG_FILES([
Makefile
doc/Makefile