summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-09-22 11:53:21 -0700
committerJamey Sharp <jamey@minilop.net>2006-09-22 15:11:39 -0700
commit2538acd8c89d73e8c074849c63857cb899a29bbb (patch)
treed62806e35dae9deb690fe02a90fe81b46107d004 /src/Makefile.am
parent2c8b5994b3fbba343199ef555594a32e29d8bcee (diff)
List xproto.xml path explicitly instead of relying on GNU Make $< expansion
(Some non-gnu makes, such as Solaris make, only recognize $< in implicit suffix rules, not explicit ones like this.)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 43f7236..0715708 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -221,7 +221,7 @@ SUFFIXES = .xml
-o $@ $(srcdir)/c-client.xsl $<
xproto.xml: $(XCBPROTO_XCBINCLUDEDIR)/xproto.xml
- $(LN_S) $< $@
+ $(LN_S) $(XCBPROTO_XCBINCLUDEDIR)/xproto.xml $@
$(EXTENSION_XML):
[ -d extensions ] || mkdir extensions