summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2006-09-25 02:02:16 -0700
committerJosh Triplett <josh@freedesktop.org>2006-09-25 02:57:19 -0700
commit9100981d359f6366ab92b456e6069bac89afeb15 (patch)
tree3099aded5768072b83251988cbdb0efb9838f426 /src/Makefile.am
parent810dfb886247dc4484886aff2e2e7d80ea945de4 (diff)
Split the Xlib compatibility functions into a separate library libxcb-xlib
We don't want to have to change the libxcb soname if we later manage to remove the Xlib compatibility functions, and nothing except Xlib should ever use them, so split them into a separate library.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f49cc38..274a884 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,5 @@
lib_LTLIBRARIES = libxcb.la \
+ libxcb-xlib.la \
libxcb-composite.la \
libxcb-damage.la \
libxcb-dpms.la \
@@ -105,7 +106,7 @@ AM_CFLAGS = $(COPTFLAGS) $(CWARNFLAGS) $(CDEBUGFLAGS) $(XCBPROTO_CFLAGS) $(XAU_C
libxcb_la_LIBADD = $(XCBPROTO_LIBS) $(XAU_LIBS) $(XDMCP_LIBS)
libxcb_la_SOURCES = \
xcb_conn.c xcb_out.c xcb_in.c xcb_ext.c xcb_xid.c \
- xcb_list.c xcb_util.c xcb_xlib.c xcb_auth.c \
+ xcb_list.c xcb_util.c xcb_auth.c \
$(COREPROTO) $(ESSENTIAL_EXTENSIONS) c-client.xsl
# Explanation for -version-info:
@@ -122,6 +123,10 @@ CLEANFILES = $(COREPROTO) $(EXTENSIONS)
XCB_LIBS = libxcb.la
+libxcb_xlib_la_LDFLAGS = -version-info 0:0:0
+libxcb_xlib_la_LIBADD = $(XCB_LIBS)
+libxcb_xlib_la_SOURCES = xcb_xlib.c
+
# FIXME: find a way to autogenerate this from the XML files.
libxcb_composite_la_LDFLAGS = -version-info 0:0:0