summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2014-01-07 14:02:21 -0500
committerArnaud Fontaine <arnau@debian.org>2014-01-30 12:10:06 +0900
commitd7eb0bdf3b5b11ee9f40ee5e73df8fc0bdfa59f3 (patch)
tree5319d783665a0d3ebc5a9c03d8a1e6ad6eb4de7f /src/Makefile.am
parente4061b8f00d301a51d4c9eef4a07f1e87592fe85 (diff)
generated man pages: use xorg footer and no hard coded extension
The section number is no longer hard-coded The left footer is now "X Version 11". The center footer is the package name with the version, "libxcb 1.9" The three values above are provided through xorg-macros. They are passed-in to the python c_client code. Example of footer (last line, above dotted line) [...] AUTHOR Generated from xproto.xml. Contact xcb@lists.freedesktop.org for cor‐ rections and improvements. X Version 11 libxcb 1.9 xcb_send_event(3) ------------------------------------------------------------------------------ Reviewed-by: Josh Triplett <josh@joshtriplett.org> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 75f0f2c..5a3c52a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -249,6 +249,8 @@ BUILT_SOURCES = $(EXTSOURCES) $(BUILT_MAN_PAGES)
CLEANFILES = $(EXTSOURCES) $(EXTHEADERS) $(BUILT_MAN_PAGES)
$(EXTSOURCES): c_client.py $(XCBPROTO_XCBINCLUDEDIR)/$(@:.c=.xml)
- $(PYTHON) $(srcdir)/c_client.py -p $(XCBPROTO_XCBPYTHONDIR) $(XCBPROTO_XCBINCLUDEDIR)/$(@:.c=.xml)
+ $(AM_V_GEN)$(PYTHON) $(srcdir)/c_client.py -c "$(PACKAGE_STRING)" -l "$(XORG_MAN_PAGE)" \
+ -s "$(LIB_MAN_SUFFIX)" -p $(XCBPROTO_XCBPYTHONDIR) \
+ $(XCBPROTO_XCBINCLUDEDIR)/$(@:.c=.xml)
$(BUILT_MAN_PAGES): $(EXTSOURCES)