summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2013-04-09 21:35:52 -0700
committerKeith Packard <keithp@keithp.com>2013-11-07 13:32:46 -0800
commita22ffa399a63a2c53aabe66efe9df01196fed74e (patch)
tree57fd9faf7ff8cb07282e5fe440c236b0dceb432f /src/Makefile.am
parent53087b12e2e0e523470bc126c14068525cd3e2cf (diff)
Add DRI3 library
Signed-off-by: Keith Packard <keithp@keithp.com> Reviewed-By: Uli Schlachter <psychon@znc.in>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f48e14e..9d6d246 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -56,6 +56,14 @@ libxcb_dri2_la_LIBADD = $(XCB_LIBS)
nodist_libxcb_dri2_la_SOURCES = dri2.c dri2.h
endif
+EXTSOURCES += dri3.c
+if BUILD_DRI3
+lib_LTLIBRARIES += libxcb-dri3.la
+libxcb_dri3_la_LDFLAGS = -version-info 0:0:0 -no-undefined @lt_enable_auto_import@
+libxcb_dri3_la_LIBADD = $(XCB_LIBS)
+nodist_libxcb_dri3_la_SOURCES = dri3.c dri3.h
+endif
+
EXTSOURCES += glx.c
if BUILD_GLX
lib_LTLIBRARIES += libxcb-glx.la