summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0c1cfaf..fb5bd4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,7 +51,11 @@ AC_SUBST(HTML_CHECK_RESULT)
# Checks for pkg-config packages
PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.13)
-NEEDED="pthread-stubs xau >= 0.99.2"
+NEEDED="xau >= 0.99.2"
+case $host_os in
+linux*) ;;
+ *) NEEDED="$NEEDED pthread-stubs" ;;
+esac
PKG_CHECK_MODULES(NEEDED, $NEEDED)
have_xdmcp="no"