summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-13 14:58:56 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-13 14:58:56 -0700
commit8418a3a9fb81c8581093621e833267055150e1d3 (patch)
tree5645181aec656dd70720434dd4ba8d8d2c59c379 /Makefile.am
parent6a0dc8f9fee906d55be46acfc7dd3dd29b3bde9a (diff)
Move Xprint protocol spec & overview man pages from xorg-docs
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 35 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 15546a5..6b2e7c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,19 @@ print_HEADERS = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = printproto.pc
-EXTRA_DIST = printproto.pc.in
+miscmandir = $(MISC_MAN_DIR)
+miscman_DATA = man/Xprint.$(MISC_MAN_SUFFIX)
+CLEANFILES = $(miscman_DATA)
+
+EXTRA_DIST = printproto.pc.in \
+ man/Xprint.man \
+ man/Xprint.sgml \
+ specs/xp_proto.book \
+ specs/xp_proto.mif \
+ specs/xp_proto.ps \
+ specs/xp_protoIX.doc \
+ specs/xp_protoTOC.doc \
+ specs/xp_proto_cov.mif
EXTRA_DIST += ChangeLog
MAINTAINERCLEANFILES = ChangeLog
@@ -17,3 +29,25 @@ ChangeLog:
$(CHANGELOG_CMD)
dist-hook: ChangeLog
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__datadir__|$(datadir)|g' \
+ -e 's|__libdir__|$(libdir)|g' \
+ -e 's|__sysconfdir__|$(sysconfdir)|g' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g'
+
+SUFFIXES = .$(MISC_MAN_SUFFIX) .man
+
+.man.$(MISC_MAN_SUFFIX): man
+ $(MKDIR_P) man
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@