summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2021-02-25 09:24:38 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2021-03-10 09:39:44 +0000
commit242578ac6ef807bf20125f0fdd14c5e4cb17e176 (patch)
treea993809c6819e74014e8cb10768c72783fbb23ef /Makefile.am
parent388aa4870a5344505297a18e8fea233f40f12693 (diff)
Integrate the keysym verifier into make check
autotools can't pass arguments, so let's default to 'verify' in the script itself and for distcheck to succeed, we need to set an environment variable to search for the header (it's an out-of-tree build). And due to the very faint chance of there being no python during the xorgproto build, let's make that conditional too. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4a39da1..3d59178 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -487,3 +487,11 @@ EXTRA_DIST = \
AM_DISTCHECK_CONFIGURE_FLAGS = --enable-legacy
+
+if HAVE_PYTHON
+AM_TESTS_ENVIRONMENT = \
+ INCLUDESDIR=$(top_srcdir)/include
+TESTS = scripts/keysym-generator.py
+TEST_EXTENSIONS = .py
+PY_LOG_COMPILER = $(PYTHON)
+endif