summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2022-07-29 09:46:34 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2022-08-05 09:51:54 +1000
commitad6412624ef6dc4d7548fe16c254c4166ffa7198 (patch)
treeca8c6ba8ca5740c68a5c5f8454af79c22772dfa7 /Makefile.am
parenta3f847b75025a57b64967d08a299bc752c488aee (diff)
Add the XWAYLAND extension
This extension exists to serve one purpose: reliably identifying Xwayland. Previous attempts at doing so included querying root window properties, output names or input device names. All these attempts are somewhat unreliable. Instead, let's use an extension - where that extension is present we have an Xwayland server. Clients should never need to do anything but check whether the extension exists through XQueryExtension/XListExtensions. This extension provides a single QueryVersion request only, and that is only to provide future compatibility if we ever need anything other than "this extension exists" functionality. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Olivier Fourdan <ofourdan@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d59178..e25650f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -326,6 +326,13 @@ xinerama_HEADERS = \
xineramaprotopkgconfigdir = $(datadir)/pkgconfig
xineramaprotopkgconfig_DATA = xineramaproto.pc
+xwaylandprotodir = $(includedir)/X11/extensions
+xwaylandproto_HEADERS = \
+ include/X11/extensions/xwaylandproto.h
+
+xwaylandprotopkgconfigdir = $(datadir)/pkgconfig
+xwaylandprotopkgconfig_DATA = xwaylandproto.pc
+
if LEGACY
XCalibrateincludedir = $(includedir)/X11/extensions
XCalibrateinclude_HEADERS = \
@@ -430,7 +437,8 @@ dist_doc_DATA = \
randrproto.txt \
renderproto.txt \
resproto.txt \
- xv-protocol-v2.txt
+ xv-protocol-v2.txt \
+ xwaylandproto.txt
EXTRA_DIST = \
COPYING-applewmproto \
@@ -469,6 +477,7 @@ EXTRA_DIST = \
COPYING-xf86rushproto \
COPYING-xf86vidmodeproto \
COPYING-xineramaproto \
+ COPYING-xwaylandproto \
README.md \
autogen.sh \
include/GL/internal/meson.build \