summaryrefslogtreecommitdiff
path: root/calibrateproto/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2017-12-13 15:12:25 -0800
committerKeith Packard <keithp@keithp.com>2017-12-13 15:12:25 -0800
commit2ed786207438dc17c14c8d8b00924a48e404da28 (patch)
tree672dd32a5c915bcc59e9cbcc31fcdc21d38b8199 /calibrateproto/Makefile.am
parent878517ddf71a63f756c18d6568723bb329ae21c8 (diff)
Move common calibrateproto files out of the way
Diffstat (limited to 'calibrateproto/Makefile.am')
-rw-r--r--calibrateproto/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/calibrateproto/Makefile.am b/calibrateproto/Makefile.am
new file mode 100644
index 0000000..2e7dee2
--- /dev/null
+++ b/calibrateproto/Makefile.am
@@ -0,0 +1,39 @@
+#
+# Copyright © 2003 Philip Blundell
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Philip Blundell not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Philip Blundell makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# PHILIP BLUNDELL DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL PHILIP BLUNDELL BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+#
+
+XCalibrateincludedir = $(includedir)/X11/extensions
+XCalibrateinclude_HEADERS = xcalibrateproto.h xcalibratewire.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = xcalibrateproto.pc
+
+EXTRA_DIST = autogen.sh xcalibrateproto.pc.in
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog