summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2018-01-12 15:04:13 -0500
committerAdam Jackson <ajax@redhat.com>2018-01-16 11:13:00 -0500
commit23fe271e30d10e6e83ab403bf07c144440c201a0 (patch)
treee3371247b41fd326317647bb2edcd3ca1a225f95 /configure.ac
parent7519914301a5cb2c5f0aedc5582f0da0e6eb3cdb (diff)
build: Hide some ancient headers behind --enable-legacy
Use this if you need calibrate, evie, fontcache, lg3d, or print. Signed-off-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7bdb45f..44b0a40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,12 @@ AC_CONFIG_HEADERS([Xfuncproto.h])
AC_CANONICAL_HOST
+AC_ARG_ENABLE(legacy,
+ AS_HELP_STRING([--enable-legacy],
+ [Install legacy protocol headers (default: false)]),
+ [LEGACY=$enableval], [LEGACY=no])
+AM_CONDITIONAL(LEGACY, [test "x$LEGACY" = "xyes"])
+
# Check for enable/disable options
AC_ARG_ENABLE(function-prototypes,
AS_HELP_STRING([--enable-function-prototypes],