summaryrefslogtreecommitdiff
path: root/evieproto/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2017-12-13 15:12:25 -0800
committerKeith Packard <keithp@keithp.com>2017-12-13 15:12:25 -0800
commita9e6d97b07e66f79b5b464972c5a4f468762124f (patch)
treecd304eb38809696987ce810493cf83d888455e03 /evieproto/Makefile.am
parent8780f0d2a08f5d0ad600e11195118226b356f4b6 (diff)
Move common evieproto files out of the way
Diffstat (limited to 'evieproto/Makefile.am')
-rw-r--r--evieproto/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/evieproto/Makefile.am b/evieproto/Makefile.am
new file mode 100644
index 0000000..6de80c3
--- /dev/null
+++ b/evieproto/Makefile.am
@@ -0,0 +1,21 @@
+eviedir = $(includedir)/X11/extensions
+evie_HEADERS = \
+ evieproto.h \
+ Xeviestr.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = evieproto.pc
+
+EXTRA_DIST = evieproto.pc.in
+
+MAINTAINERCLEANFILES = ChangeLog INSTALL
+
+.PHONY: ChangeLog INSTALL
+
+INSTALL:
+ $(INSTALL_CMD)
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog INSTALL