summaryrefslogtreecommitdiff
path: root/include/X11/extensions/meson.build
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2018-01-31 13:31:53 -0500
committerAdam Jackson <ajax@redhat.com>2018-02-01 15:01:56 -0500
commit193b75db8c1aa9d91d079901d7da98ec72810378 (patch)
tree016f228b0046db822ec41668100a899a13143a49 /include/X11/extensions/meson.build
parent0d4330017c811227f8424ecbd061d987f39b4e9f (diff)
meson: Spread the install rules into their subdirs
Mostly this is is so the generated Xpoll.h can be emitted into a usable directory when we build as a subproject. Signed-off-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'include/X11/extensions/meson.build')
-rw-r--r--include/X11/extensions/meson.build122
1 files changed, 122 insertions, 0 deletions
diff --git a/include/X11/extensions/meson.build b/include/X11/extensions/meson.build
new file mode 100644
index 0000000..e7e7de2
--- /dev/null
+++ b/include/X11/extensions/meson.build
@@ -0,0 +1,122 @@
+install_headers(
+ 'ag.h',
+ 'agproto.h',
+ 'applewmconst.h',
+ 'applewmproto.h',
+ 'bigreqsproto.h',
+ 'bigreqstr.h',
+ 'composite.h',
+ 'compositeproto.h',
+ 'cup.h',
+ 'cupproto.h',
+ 'damageproto.h',
+ 'damagewire.h',
+ 'dbe.h',
+ 'dbeproto.h',
+ 'dmx.h',
+ 'dmxproto.h',
+ 'dpmsconst.h',
+ 'dpmsproto.h',
+ 'dri2proto.h',
+ 'dri2tokens.h',
+ 'dri3proto.h',
+ 'EVI.h',
+ 'EVIproto.h',
+ 'ge.h',
+ 'geproto.h',
+ 'lbx.h',
+ 'lbxproto.h',
+ 'mitmiscconst.h',
+ 'mitmiscproto.h',
+ 'multibufconst.h',
+ 'multibufproto.h',
+ 'panoramiXproto.h',
+ 'presentproto.h',
+ 'presenttokens.h',
+ 'randr.h',
+ 'randrproto.h',
+ 'recordconst.h',
+ 'recordproto.h',
+ 'recordstr.h',
+ 'render.h',
+ 'renderproto.h',
+ 'saver.h',
+ 'saverproto.h',
+ 'secur.h',
+ 'securproto.h',
+ 'shapeconst.h',
+ 'shapeproto.h',
+ 'shapestr.h',
+ 'shm.h',
+ 'shmproto.h',
+ 'shmstr.h',
+ 'syncconst.h',
+ 'syncproto.h',
+ 'syncstr.h',
+ 'vldXvMC.h',
+ 'windowswm.h',
+ 'windowswmstr.h',
+ 'xcmiscproto.h',
+ 'xcmiscstr.h',
+ 'xf86bigfont.h',
+ 'xf86bigfproto.h',
+ 'xf86bigfstr.h',
+ 'xf86dga1const.h',
+ 'xf86dga1proto.h',
+ 'xf86dga1str.h',
+ 'xf86dgaconst.h',
+ 'xf86dga.h',
+ 'xf86dgaproto.h',
+ 'xf86dgastr.h',
+ 'xf86misc.h',
+ 'xf86mscstr.h',
+ 'xf86vm.h',
+ 'xf86vmproto.h',
+ 'xf86vmstr.h',
+ 'xfixesproto.h',
+ 'xfixeswire.h',
+ 'XI2.h',
+ 'XI2proto.h',
+ 'XI.h',
+ 'XIproto.h',
+ 'XKBgeom.h',
+ 'XKB.h',
+ 'XKBproto.h',
+ 'XKBsrv.h',
+ 'XKBstr.h',
+ 'XResproto.h',
+ 'xtestconst.h',
+ 'xtestext1const.h',
+ 'xtestext1proto.h',
+ 'xtestproto.h',
+ 'xtrapbits.h',
+ 'xtrapddmi.h',
+ 'xtrapdi.h',
+ 'xtrapemacros.h',
+ 'xtraplib.h',
+ 'xtraplibp.h',
+ 'xtrapproto.h',
+ 'Xv.h',
+ 'XvMC.h',
+ 'XvMCproto.h',
+ 'Xvproto.h',
+ subdir : 'X11/extensions'
+)
+
+if get_option('legacy') == true
+ install_headers(
+ 'evieproto.h',
+ 'fontcache.h',
+ 'fontcacheP.h',
+ 'fontcachstr.h',
+ 'lgewire.h',
+ 'Print.h',
+ 'Printstr.h',
+ 'xcalibrateproto.h',
+ 'xcalibratewire.h',
+ 'Xeviestr.h',
+ 'xf86rush.h',
+ 'xf86rushstr.h',
+ subdir : 'X11/extensions'
+ )
+endif