summaryrefslogtreecommitdiff
path: root/include/X11/extensions/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2022-07-29 09:46:34 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2022-08-05 09:51:54 +1000
commitad6412624ef6dc4d7548fe16c254c4166ffa7198 (patch)
treeca8c6ba8ca5740c68a5c5f8454af79c22772dfa7 /include/X11/extensions/meson.build
parenta3f847b75025a57b64967d08a299bc752c488aee (diff)
Add the XWAYLAND extension
This extension exists to serve one purpose: reliably identifying Xwayland. Previous attempts at doing so included querying root window properties, output names or input device names. All these attempts are somewhat unreliable. Instead, let's use an extension - where that extension is present we have an Xwayland server. Clients should never need to do anything but check whether the extension exists through XQueryExtension/XListExtensions. This extension provides a single QueryVersion request only, and that is only to provide future compatibility if we ever need anything other than "this extension exists" functionality. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Olivier Fourdan <ofourdan@redhat.com>
Diffstat (limited to 'include/X11/extensions/meson.build')
-rw-r--r--include/X11/extensions/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/X11/extensions/meson.build b/include/X11/extensions/meson.build
index d1ac281..9c91f22 100644
--- a/include/X11/extensions/meson.build
+++ b/include/X11/extensions/meson.build
@@ -87,6 +87,7 @@ install_headers(
'XvMC.h',
'XvMCproto.h',
'Xvproto.h',
+ 'xwaylandproto.h',
subdir : 'X11/extensions'
)