summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-16 13:15:14 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-16 13:24:51 -0700
commitcf35a91fe57d4721a173d2bc428dd07dcc4674f9 (patch)
tree00fa94f385cdfdbe35948b22556942941585750f /meson.build
parent423098656f145afeb72cbf21aaa0b3a3f9bc36bb (diff)
Only install PM_spec when legacy protocol support is enabled
PM_spec is the spec for the Proxy Management Protocol, and the other files for that protocol are only installed if legacy protocols are requested from configure or meson Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b8d2e44..2967d8b 100644
--- a/meson.build
+++ b/meson.build
@@ -75,7 +75,6 @@ docs = files('compositeproto.txt',
'dri2proto.txt',
'dri3proto.txt',
'fixesproto.txt',
- 'PM_spec',
'presentproto.txt',
'randrproto.txt',
'renderproto.txt',
@@ -107,6 +106,9 @@ if get_option('legacy') == true
configuration : pc_data,
)
endforeach
+ legacy_docs = files('PM_spec')
+ install_data(legacy_docs,
+ install_dir: get_option('datadir') / 'doc' / 'xorgproto')
endif
ext_xorgproto = declare_dependency(