summaryrefslogtreecommitdiff
path: root/printproto/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2017-12-13 15:12:26 -0800
committerKeith Packard <keithp@keithp.com>2017-12-13 15:12:26 -0800
commit7c14e8e1dbd9c613921ca25d9d19703b36b25fdb (patch)
treefd11109e0acd92a61bb37b2214f954a04c365422 /printproto/Makefile.am
parentdc2028a003f31e4f93ee895bba8cfac125fc1573 (diff)
Move common printproto files out of the way
Diffstat (limited to 'printproto/Makefile.am')
-rw-r--r--printproto/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/printproto/Makefile.am b/printproto/Makefile.am
new file mode 100644
index 0000000..6b2e7c8
--- /dev/null
+++ b/printproto/Makefile.am
@@ -0,0 +1,53 @@
+printdir = $(includedir)/X11/extensions
+print_HEADERS = \
+ Print.h \
+ Printstr.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = printproto.pc
+
+miscmandir = $(MISC_MAN_DIR)
+miscman_DATA = man/Xprint.$(MISC_MAN_SUFFIX)
+CLEANFILES = $(miscman_DATA)
+
+EXTRA_DIST = printproto.pc.in \
+ man/Xprint.man \
+ man/Xprint.sgml \
+ specs/xp_proto.book \
+ specs/xp_proto.mif \
+ specs/xp_proto.ps \
+ specs/xp_protoIX.doc \
+ specs/xp_protoTOC.doc \
+ specs/xp_proto_cov.mif
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__datadir__|$(datadir)|g' \
+ -e 's|__libdir__|$(libdir)|g' \
+ -e 's|__sysconfdir__|$(sysconfdir)|g' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g'
+
+SUFFIXES = .$(MISC_MAN_SUFFIX) .man
+
+.man.$(MISC_MAN_SUFFIX): man
+ $(MKDIR_P) man
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@