summaryrefslogtreecommitdiff
path: root/specs/kbproto/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2019-02-23 13:33:41 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2019-02-23 15:22:32 -0800
commit4feff33159efb139ddb89a90fb26ad646b288f2b (patch)
treeb36ecded595ec090c1df48636dec7ea51751b16b /specs/kbproto/Makefile.am
parenteb2c0108e495ff2a5febcc87234780c3a249f49f (diff)
Restore generation of specs from docbook in autotools builds
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'specs/kbproto/Makefile.am')
-rw-r--r--specs/kbproto/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/specs/kbproto/Makefile.am b/specs/kbproto/Makefile.am
new file mode 100644
index 0000000..05719a9
--- /dev/null
+++ b/specs/kbproto/Makefile.am
@@ -0,0 +1,48 @@
+
+if ENABLE_SPECS
+
+# Main DocBook/XML files (DOCTYPE book)
+docbook = xkbproto.xml
+
+# Included chapters, appendix, images
+chapters = \
+ acknowledgements.xml \
+ appA.xml \
+ appB.xml \
+ appC.xml \
+ appD.xml \
+ ch01.xml \
+ ch02.xml \
+ ch03.xml \
+ ch04.xml \
+ ch05.xml \
+ ch06.xml \
+ ch07.xml \
+ ch08.xml \
+ ch09.xml \
+ ch10.xml \
+ ch11.xml \
+ ch12.xml \
+ ch13.xml \
+ ch14.xml \
+ ch15.xml \
+ ch16.xml \
+ XKBproto-1.svg \
+ XKBproto-2.svg \
+ XKBproto-3.svg \
+ XKBproto-4.svg \
+ XKBproto-5.svg \
+ XKBproto-6.svg \
+ XKBproto-7.svg \
+ XKBproto-8.svg \
+ XKBproto-9.svg \
+ XKBproto-10.svg \
+ XKBproto-11.svg
+
+# The location where the DocBook/XML files and their generated formats are installed
+shelfdir = $(datarootdir)/doc/kbproto
+
+# Generate DocBook/XML output formats with or without stylesheets
+include $(top_srcdir)/docbook.am
+
+endif ENABLE_SPECS