summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4a39da1..3d59178 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -487,3 +487,11 @@ EXTRA_DIST = \
AM_DISTCHECK_CONFIGURE_FLAGS = --enable-legacy
+
+if HAVE_PYTHON
+AM_TESTS_ENVIRONMENT = \
+ INCLUDESDIR=$(top_srcdir)/include
+TESTS = scripts/keysym-generator.py
+TEST_EXTENSIONS = .py
+PY_LOG_COMPILER = $(PYTHON)
+endif