summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 0 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 4c2db89..f20c0e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,10 +65,6 @@ AC_ARG_ENABLE(nested-prototypes,
AS_HELP_STRING([--enable-nested-prototypes],
[nested prototypes are supported (default: auto)]),
[NESTEDPROTO=$enableval], [NESTEDPROTO=auto])
-AC_ARG_ENABLE(wide-prototypes,
- AS_HELP_STRING([--enable-wide-prototypes],
- [widen function prototypes (default: auto)]),
- [WIDEPROTO=$enableval], [WIDEPROTO=auto])
AC_CHECK_HEADERS([sys/select.h sys/param.h sys/types.h sys/time.h])
@@ -219,22 +215,6 @@ else
fi
fi
-AC_MSG_CHECKING([whether to widen function prototypes])
-if test "x$WIDEPROTO" = xauto; then
- case $host_os in
- linux*) WIDEPROTO=no ;;
- freebsd*) WIDEPROTO=no ;;
- netbsd*) WIDEPROTO=no ;;
- openbsd*) WIDEPROTO=no ;;
- *) WIDEPROTO=yes ;;
- esac
-fi
-AC_MSG_RESULT([$WIDEPROTO])
-
-if test "x$WIDEPROTO" = xno; then
- AC_DEFINE(NARROWPROTO, [], [Narrow prototypes])
-fi
-
AC_CONFIG_FILES([applewmproto.pc
bigreqsproto.pc
compositeproto.pc